AIMP Forum

AIMP для Windows => Предложения => Topic started by: megapro17 on January 14, 2021, 01:14:03

Title: обновите версию ffmpeg
Post by: megapro17 on January 14, 2021, 01:14:03
В плеере используется очень древняя версия 3.2.4 которая не может открыть множество кодеков, например wma2, at9 и другие, так что прошу её обновить
Title: Re: обновите версию ffmpeg
Post by: Artem on January 14, 2021, 08:10:42
FFmpeg используется в AIMP лишь для малого количества форматов - ATRAC / Matroska / WebM. WMA и WMA2 декодируется средствами ОС. AT9 формат никогда не поддерживался (да и слышу я о нем впервые).
Если бы у версий FFmpeg была обратная совместимость по API - обновился бы без проблем, однако ее нет, и поэтому весь плагин придется переписывать под новую версию.

Title: Re: обновите версию ffmpeg
Post by: megapro17 on January 15, 2021, 01:32:50
Разве всё так плохо? Действительно придётся переписывать весь плагин?
В теории можно было бы выкинуть все декодеры и открывать все файлы с помощью ffmpeg
Title: Re: обновите версию ffmpeg
Post by: Artem on January 15, 2021, 09:03:24
Разве всё так плохо? Действительно придётся переписывать весь плагин?

Плохо, не плохо, а нужно взять их заголовки и все их заново перевести.

В теории можно было бы выкинуть все декодеры и открывать все файлы с помощью ffmpeg

Да, я даже планировал когда-то это сделать, но забил - т.к. за это время можно сделать что-то другое, более полезное.