AIMP Forum

AIMP для Android => Ошибки / Замечания => Topic started by: Nirox on March 09, 2020, 22:21:22

Title: FiiO M6 и пропажа звука при переходе на новый трек.
Post by: Nirox on March 09, 2020, 22:21:22
Есть железка FiiO M6 по качеству звука вопросов минимум, но вот внутренний плеер тихий ужАс. С недавних пор штатными способами можно ставить AIMP и все было хорошо, но вот такая вот штука наблюдается. При переходе к новому треку начинается воспроизведение, потом резко пропадает звук но время идет. Если поставить на паузу и включить опять, звук появляется. Проверял на разных файлах, результат один и тот же. Стоит сейчас самая последняя версия и сборка AIMP for Android v3.01, build 967

Думал что проблема в сведении звука, выключил эту опции (она и не всегда нужна). Но результат тот же увы. Подскажите что не так, может мне какие тесты еще сделать, чтобы отловить багу? Уж очень он нужен на FiiO M6 ибо ну без него вообще железка сама по себе.... А китайчата на родной плеер походу забили болт, развивают только тех часть.
Title: Re: FiiO M6 и пропажа звука при переходе на новый трек.
Post by: Artem on March 10, 2020, 11:05:30
Что за устройство? андроид какой?
Title: Re: FiiO M6 и пропажа звука при переходе на новый трек.
Post by: Nirox on March 10, 2020, 11:58:57
Устройство: плеер FiiO M6 версия андройда 7.0 но как они сами пишут, очень переделанная под качество звука.  Хз что это значит.
Title: Re: FiiO M6 и пропажа звука при переходе на новый трек.
Post by: Artem on March 10, 2020, 17:10:21
А, это самостоятельное устройство! Я неправильно понял вас изначально. Попробуйте переключить вывод звука на AudioTrack в настройках программы.
Title: Re: FiiO M6 и пропажа звука при переходе на новый трек.
Post by: Nirox on March 11, 2020, 20:29:58
Этот и второй режим я попробовал сразу. Увы проблема сохраняется. Поставил еще некий Pulsar там такой проблемы нет, но AIMP как-то роднее, еще с времен Windows да и устраивает полностью по удобству и главное скорость работы. Но вот этот момент, с пропажей звука в начале трека, не дает полноценно им наслаждаться. Одно заметил, всегда первые 3-4 сек есть звук, потом пропал. Т.е. не прям с начала трека, а 3-4 сек он еще как бы захватывает.

Что я еще могу попробовать, чтобы помочь это исправить?
Title: Re: FiiO M6 и пропажа звука при переходе на новый трек.
Post by: Artem on March 11, 2020, 23:13:28
А пробовали отключать плавный переход, затухание звука и т.п. в настройках программы?
Title: Re: FiiO M6 и пропажа звука при переходе на новый трек.
Post by: Nirox on March 12, 2020, 07:58:10
Да. Об этом я упомянул в первом моем посте.  :-[
Title: Re: FiiO M6 и пропажа звука при переходе на новый трек.
Post by: Artem on March 12, 2020, 09:19:38
Да. Об этом я упомянул в первом моем посте.  :-[

Да, точно. Это я проглядел. Нашел БУ-шный вариант устройства на ебее, заказал, буду ждать доставки.
Title: Re: FiiO M6 и пропажа звука при переходе на новый трек.
Post by: Nirox on March 12, 2020, 11:17:02
ого, радикальное решение :)

Если надо будет еще что-то проверить с моей стороны, говорите. Сделаю.
Title: Re: FiiO M6 и пропажа звука при переходе на новый трек.
Post by: Artem on March 17, 2020, 12:18:43
Приехало устройство. Пришлось помучаться с апгрейдом, но все поднялось. Поставил релизную версию плеера - вроде все работает корректно. Какие настройки вывода звука вы используете? На всех ли треках возникает эта проблема?
Title: Re: FiiO M6 и пропажа звука при переходе на новый трек.
Post by: Nirox on March 17, 2020, 13:10:31
Выводы звука в плеере или в системных настройках самого устройства?

Сегодня вечером напишу (плеер не с собой) что выставлено в плеере, что выставлено в системных. Еще раз проверю на разных треках (хотя это проверял, проблема сохраняется). Но проверю еще раз.

А какие параметры звука в плеере и системных настройках у вас сейчас?
Title: Re: FiiO M6 и пропажа звука при переходе на новый трек.
Post by: Artem on March 17, 2020, 14:09:37
А какие параметры звука в плеере и системных настройках у вас сейчас?

Всё по умолчанию.
Title: Re: FiiO M6 и пропажа звука при переходе на новый трек.
Post by: Nirox on March 17, 2020, 15:19:04
Понял, сегодня вечером напишу детали, что используются и если смогу скину файлы. Проверю еще раз на других файлах (хотя они же в Pulsar играют без проблем).
Title: Re: FiiO M6 и пропажа звука при переходе на новый трек.
Post by: Nirox on March 18, 2020, 21:45:03
Итого еще раз:

Источник звука: FiiO M6
Подключение: ATH M50-xBT кодек aptX

Настройки в системе: Select output = PO
Digital filter mode = Fast Roll-Off
Wireless playback quality = LDAC-Sound quality first

В самом плеере AIMP
Метод вывода звука = Auto/OpenSL/AudioTrack  (пробовал все)
Частота дискретизации = Auto
Алгоритм передискретизации = Очень качественный
16 битный вывод = ДА
Высокий приоритет ЦП = НЕТ
Сводить в моно = НЕТ

Файлы для тестов: (только с целью ознакомления) https://rutracker.org/forum/viewtopic.php?t=5854479


Следующим шагом планирую обновить наушники, но там что-то намудрили ребята и процесс под 2 часа.... отпишусь. Будет смешно, если это чисто связка уши-плеер так реагируют. Хотя не замечал за ними такого, обычно играют все и со всеми источниками. 
Title: Re: FiiO M6 и пропажа звука при переходе на новый трек.
Post by: Nirox on March 18, 2020, 22:23:24
Обновил наушники, не знал честно говоря, что есть новая прошивка до начала эскперементов. В данный момент такой проблемы не наблюдаю. Дико извиняюсь за доставленые хлопоты с покупкой железки. Но буду крайне благодарен и признателен, если вы и дальше будите ее поддерживать и ваш плеер будет на ней так же прекрасно и быстро работать.
Title: Re: FiiO M6 и пропажа звука при переходе на новый трек.
Post by: Artem on March 19, 2020, 09:56:57
Спасибо.