AIMP Forum

English pages => Questions => Topic started by: Biff on March 04, 2020, 01:56:50

Title: When Aimp plays a track sometimes no covers shown?
Post by: Biff on March 04, 2020, 01:56:50
When Aimp plays a track of this folder
I:\Musik\The FIXX\The Fixx - Diskografie\2003 - Want That Life\
no image / cover is shown.

The images are here:
I:\Musik\The FIXX\The Fixx - Diskografie\2003 - Want That Life\Scans\

How could I correct it?

(https://i.imgur.com/hDvjTQO.png)

I have this lines added:

Quote
folder.*
folder.gif
folder.jpg
front.*
front.jpg
*cover*
*folder*
*front*
cover.*
covers\*front*
Cover\*cover*
Cover\*folder*
Cover\*front*
Scan*\*
Scan*\*cover*
Scan*\*folder*
Scan*\*front*
covers\*
Cover\*
Artwork\*
Artwork\*cover*
Artwork\*folder*
Artwork\*front*
art\*cover*
art\*folder*
art\*front*
*
*%filename%*
..\Scans\*
..\Cover\*
..\..\covers\*\*
..\Scan\*
..\images\*
..\image\*
..\art\*
..\fanart\*
*.*
*\*
*\*.*
..\*\*.*
..\*.*
Title: Re: When Aimp plays a track sometimes no covers shown?
Post by: Artem on March 04, 2020, 09:24:50
Code: [Select]
Scan*\*
Scan*\*cover*
Scan*\*folder*
Scan*\*front*

the "*" are supported for files only. You should define scan\ and scans\ folders separately
Title: Re: When Aimp plays a track sometimes no covers shown?
Post by: Biff on March 04, 2020, 10:13:01
Many thanks.

So I have to do it like this (separated scan and scans folders), remove all of the old content and replace it with the new lines(?):

(https://i.imgur.com/QhVA9MM.png)
Title: Re: When Aimp plays a track sometimes no covers shown?
Post by: JD on March 04, 2020, 10:19:54
I think the asterisks after "scan" and "scans" are superfluous
Title: Re: When Aimp plays a track sometimes no covers shown?
Post by: Biff on March 04, 2020, 11:16:38
The "*" needed to include / support all files, if I understand it right?
Title: Re: When Aimp plays a track sometimes no covers shown?
Post by: JD on March 04, 2020, 11:34:42
Just "Scan\*"
not "Scan*\*"
Title: Re: When Aimp plays a track sometimes no covers shown?
Post by: Biff on March 04, 2020, 11:51:19
OK, but actually I wouldn't doubt what Artem says. Or is there any mistake I did?
Title: Re: When Aimp plays a track sometimes no covers shown?
Post by: JD on March 04, 2020, 12:33:51
Artem meant that you can't use directory wildcards, instead of writing "Scan*" use two separate ones - "Scan" and "Scans"
Title: Re: When Aimp plays a track sometimes no covers shown?
Post by: Biff on March 04, 2020, 13:45:17
Sorry, so then this is correct (used without using my old lines)(?):

Code: [Select]
Scan\*
Scan\*cover*
Scan\*folder*
Scan\*front*
Scans\*
Scans\*cover*
Scans\*folder*
Scans\*front*
Title: Re: When Aimp plays a track sometimes no covers shown?
Post by: JD on March 04, 2020, 14:08:44
Sorry, so then this is correct (used without using my old lines)(?):
Yep
Title: Re: When Aimp plays a track sometimes no covers shown?
Post by: Biff on March 04, 2020, 15:05:53
So this finally is like it should look like:
(https://i.imgur.com/0jMrYOa.png)

But why are here added asterisks after Scan although they are not needed:
Code: [Select]
Scan*\*
Scan*\*cover*
Scan*\*folder*
Scan*\*front*