AIMP Forum

English pages => Bugs => Topic started by: openforu on March 08, 2019, 19:42:31

Title: Sliders, buttons response time. Delayed (all effects/DSP disabled)
Post by: openforu on March 08, 2019, 19:42:31
For first, its not quailty and effects settings problem or hardware. It happens to everyone on every PC.
Im talking about reaction time, I have disabled all DSP effects, smoothing and fading.
So, from Aimp 3 and up there is some very annoying lag/delay on changing volume and position, playing, pausing. Even entering in settings.
I have disabled all effects, so is basicly same setting on Aimp 2 and 4.. But Aimp 2 is working better without any delays.

Checked some programs and:
Aimp 2 = no delay
Media Player Classic = no delay
Windows Media Player = no delay
Winamp = no delay

Aimp 3 & 4 = delay exist!

Video about this problem: (see how aimp 2 is doing everything immediately?)
https://www.youtube.com/watch?v=WlhwUM9MEi0 (https://www.youtube.com/watch?v=WlhwUM9MEi0)
Fix it please. Its propably engine problem.
Title: Re: Annoying delay (all effects/DSP disabled)
Post by: Artem on March 08, 2019, 19:49:35
Did you disable the "Use sound fading on pause / unpause" and "Use sound fading on navigation within track" effects?
What output setting are set in your case?
Title: Re: Sliders, buttons response time. Delayed (all effects/DSP disabled)
Post by: openforu on March 08, 2019, 19:51:12
Like I said, all effects is disabled. Up there  :-\
Output settings > Occurs regardless of the setting, tried all

Im talking about program reaction time itself
Title: Re: Sliders, buttons response time. Delayed (all effects/DSP disabled)
Post by: Artem on March 08, 2019, 19:54:44
Like I said, all effects is disabled. Up there  :-\
Output settings > Which I would not set, the problem occurs

I cannot reproduce this issue on default settings but with disabled these effects. Note that changing output settings may leads to increase internal buffer size, so, large buffer leads to larger delay.
Title: Re: Sliders, buttons response time. Delayed (all effects/DSP disabled)
Post by: openforu on March 08, 2019, 19:57:00
Because default settings is full of effects that is hiding the issue.
On Aimp 2 I have the best output settings. No delays.
Aimp 4 bad or best, always delayed.
Title: Re: Sliders, buttons response time. Delayed (all effects/DSP disabled)
Post by: Artem on March 08, 2019, 20:00:39
Because default settings is full of effects that is hiding the issue.
On Aimp 2 I have the best output settings. No delays.

Did you read my answer?
Title: Re: Sliders, buttons response time. Delayed (all effects/DSP disabled)
Post by: openforu on March 08, 2019, 20:04:44
Yes.

Aimp 2 - 44,100Hz - 32bits no delays
Aimp 4 - DirectSound - 44,100Hz - 32bits  delayed
Aimp 4 - DirectSound - 8000Hz - 8bit still delayed

So it is not output setting problem.
Title: Re: Sliders, buttons response time. Delayed (all effects/DSP disabled)
Post by: Artem on March 08, 2019, 20:05:35
AIMP2 is simplier as a stump. It does not have these output settings, its play only via DirectSound interface (that was deprecated with release of Windows Vista), it does not have high quality resampler, sound effects and many other things. Of course, you can setup the AIMP4 like AIMP2.

Any way, this is an audio player, not a proffessional software for sound making, so, I see no serious issues with latency ~0.3 seconds.
Title: Re: Sliders, buttons response time. Delayed (all effects/DSP disabled)
Post by: Artem on March 08, 2019, 20:05:57
Aimp 2 - 44,100Hz - 32bits no delays
Aimp 4 - DirectSound - 44,100Hz - 32bits  delayed
Aimp 4 - DirectSound - 8000Hz - 8bit still delayed

But I have no delays with these settings...
Title: Re: Sliders, buttons response time. Delayed (all effects/DSP disabled)
Post by: openforu on March 08, 2019, 20:11:23
Oh, I misunderstanded you.
Title: Re: Sliders, buttons response time. Delayed (all effects/DSP disabled)
Post by: openforu on March 08, 2019, 20:17:59
Any way, this is an audio player, not a proffessional software for sound making, so, I see no serious issues with latency ~0.3 seconds.

When im searching for specific part between dozens songs, that little delay is very uncomfortable.
But why volume slider is delayed too? Although the volume slider should work with 0.0 latency
Title: Re: Sliders, buttons response time. Delayed (all effects/DSP disabled)
Post by: Artem on March 08, 2019, 20:48:34
But why volume slider is delayed too? Although the volume slider should work with 0.0 latency

Because of:
1. buffer size (we are changing volume on our side, not on system like in AIMP2, because of ASIO and WASAPI Exclusive)
2. By default, fading effect is used for better perception
Title: Re: Sliders, buttons response time. Delayed (all effects/DSP disabled)
Post by: openforu on March 09, 2019, 00:30:02
Tried ASIO, and its working better, now without delay.
But im not sure its caused by buffer size. Hmm

ASIO, buffer size: 2kb = no delay
DirectSound 96KHz, 32bit, 7.1, buffer size: 600kb delayed
DirectSound 8KHz, 8bit, mono, buffer size: 1,56kb but delay same as on 600kb

BTW that buffer size slider is changing anything?