AIMP Forum

AIMP для Android => Ошибки / Замечания => Исправлено / Обработано => Topic started by: Riccio on December 06, 2017, 13:50:09

Title: [+] [435] Нет звука при воспроизведении WAV, заикания при воспроизведении flac
Post by: Riccio on December 06, 2017, 13:50:09
Здравствуйте!
Проблемы две:
1. Началось заикание/перескакивание при воспроизведении файлов (FLUC, другие не проверял), как на виниле при соскакивании иглы. Началось вроде бы после обновления, или после предыдущего обновления, раньше не замечал.
2. При воспроизведении WAV нет звука. Плеер показывает, что играет его, ошибок никаких не выдаёт, звука нет. На ПК все те же файлы играет без проблем.
P.S. Android 7.0, LG M400DY, AIMP 2.60, build 435
Title: Re: Нет звука при воспроизведении WAV, заикания при воспроизведении fluc
Post by: Soolo on December 06, 2017, 13:55:13
Нужны примеры файлов
Title: Re: [435] Нет звука при воспроизведении WAV, заикания при воспроизведении fluc
Post by: Riccio on December 06, 2017, 15:01:43
Не знаю есть ли смысл высылать FLUC-и, это заикание никак не систематизируется, оно гуляет. Один и тот же файл может один раз проиграть с заиканием, а другой раз, совершенно нормально. На ПК они нормально воспроизводятся, через тот же AIMP.
А вот WAV смогу только вечером прицепить, сейчас нет возможности.
P.S. WAV-ы по 40МБ, не пропускает(( тут только 4МБ
Title: Re: [435] Нет звука при воспроизведении WAV, заикания при воспроизведении fluc
Post by: Artem on December 06, 2017, 15:51:58
а что такое Fluc?

Не знаю есть ли смысл высылать FLUC-и, это заикание никак не систематизируется, оно гуляет. Один и тот же файл может один раз проиграть с заиканием, а другой раз, совершенно нормально. На ПК они нормально воспроизводятся, через тот же AIMP.

Вы не забывайте, что телефон - есть телефон. Это совсем другое железо, другая ОС. Какие настройки вывода звука вы используете в мобильной версии плеера?

А вот WAV смогу только вечером прицепить, сейчас нет возможности.
P.S. WAV-ы по 40МБ, не пропускает(( тут только 4МБ

Пожалуйста, залейте куда-нибудь на обменник, например: disk.yandex.ru
Title: Re: [435] Нет звука при воспроизведении WAV, заикания при воспроизведении fluc
Post by: Riccio on December 06, 2017, 15:58:55
а что такое Fluc?
FLAC конечно))

Вы не забывайте, что телефон - есть телефон. Это совсем другое железо, другая ОС. Какие настройки вывода звука вы используете в мобильной версии плеера?
Настройки по умолчанию, ничего не менял. (в скрине настройки звука)

Пожалуйста, залейте куда-нибудь на обменник, например: disk.yandex.ru
Title: Re: [?] [435] Нет звука при воспроизведении WAV, заикания при воспроизведении fluc
Post by: Soolo on December 06, 2017, 16:02:48
Riccio, попробуйте метод вывода AudioTrack - это как вариант для "fluc"
А по поводу WAV - файлообменники рулят (п.4.10 (https://www.aimp.ru/forum/index.php?topic=74.0))
Title: Re: [435] Нет звука при воспроизведении WAV, заикания при воспроизведении fluc
Post by: Riccio on December 06, 2017, 16:03:07
а что такое Fluc?
FLAC конечно))

Вы не забывайте, что телефон - есть телефон. Это совсем другое железо, другая ОС. Какие настройки вывода звука вы используете в мобильной версии плеера?
Настройки по умолчанию (скрин)

Пожалуйста, залейте куда-нибудь на обменник, например: disk.yandex.ru
[/quote]
Title: Re: [?] [435] Нет звука при воспроизведении WAV, заикания при воспроизведении fluc
Post by: Riccio on December 06, 2017, 16:04:45
Riccio, попробуйте метод вывода AudioTrack - это как вариант для "fluc"
А по поводу WAV - файлообменники рулят (п.4.10 (https://www.aimp.ru/forum/index.php?topic=74.0))

Собственно файл:
http://rgho.st/8ThkZN4fD#
Title: Re: [?] [435] Нет звука при воспроизведении WAV, заикания при воспроизведении flac
Post by: Artem on December 07, 2017, 21:57:48
Так этот файл реально пустой - он забит сплошняком нулями.
Title: Re: [?] [435] Нет звука при воспроизведении WAV, заикания при воспроизведении flac
Post by: Riccio on December 08, 2017, 09:13:12
Так этот файл реально пустой - он забит сплошняком нулями.
Очень странно  :o на компе-то он играет. Не мог же я несколько лет нули слушать ???
По поводу FLAC, после переключения на Audio Track, заикание пропало)
Title: Re: [?] [435] Нет звука при воспроизведении WAV, заикания при воспроизведении flac
Post by: Soolo on December 08, 2017, 09:38:57
Очень странно  :o на компе-то он играет. Не мог же я несколько лет нули слушать ???
Значит при передаче на телефон произошёл сбой.
Попробуйте сами скачать этот файл и проиграть на компе
Title: Re: [?] [435] Нет звука при воспроизведении WAV, заикания при воспроизведении flac
Post by: Riccio on December 08, 2017, 09:47:59
Значит при передаче на телефон произошёл сбой.
Попробуйте сами скачать этот файл и проиграть на компе

Да, надо будет проверить.
Интересно только, почему OpenSL заикает, а Audio Track нет? :)
В общем, наверное тему закрыть уже можно.
Спасибо.
Title: Re: [?] [435] Нет звука при воспроизведении WAV, заикания при воспроизведении flac
Post by: Soolo on December 08, 2017, 09:49:18
Интересно только, почему OpenSL заикает, а Audio Track нет?
Китайские прошивки этим грешат
Title: Re: [+] [435] Нет звука при воспроизведении WAV, заикания при воспроизведении flac
Post by: Artem on December 08, 2017, 09:50:40
Очень странно  :o на компе-то он играет. Не мог же я несколько лет нули слушать ???

У меня на компе он тоже не играет.

Title: Re: [?] [435] Нет звука при воспроизведении WAV, заикания при воспроизведении flac
Post by: Riccio on December 08, 2017, 09:55:36
Китайские прошивки этим грешат

У меня чистый кореец, прошивка совсем не китайская))
Title: Re: [?] [435] Нет звука при воспроизведении WAV, заикания при воспроизведении flac
Post by: Soolo on December 08, 2017, 09:58:15
У меня чистый кореец, прошивка совсем не китайская))
Я озвучил наиболее часто встречающийся вариант проблемы с OpenSL.
Видимо, ЛыЖи тоже начали использовать китайские наработки.
Title: Re: [+] [435] Нет звука при воспроизведении WAV, заикания при воспроизведении flac
Post by: Riccio on December 08, 2017, 09:59:27
У меня на компе он тоже не играет.

В общем-то и не удивительно, раз уж там одни нули. Надо будет сравнить исходный, на компе, с тем что на смарте оказался, может действительно, как-то "побился" при передаче. Хотя всё равно странно.